Production and sandbox dashboard cannot be accessed for some users

Major incident Dashboard
2025-11-19 14:30 CET · 1 hour, 2 minutes

Updates

Resolved

This incident has been resolved.

November 19, 2025 · 15:32 CET
Monitoring

We are continuing to monitor for any further issues.

November 19, 2025 · 15:30 CET
Monitoring

A fix has been implemented and we are monitoring the results.

November 19, 2025 · 15:30 CET
Investigating

The issue has been identified and a fix is being implemented.

November 19, 2025 · 15:13 CET
Investigating

We are currently investigating this issue. The API and webhooks are not impacted.

November 19, 2025 · 14:30 CET

← Back