EU shared instance – Mambu Payments
Subscribe
to updates
Dashboard cannot be accessed
Major incident
Dashboard
2025-10-09 17:10 CEST
· 14 minutes
Updates
Resolved
This incident has been resolved.
October 9, 2025 · 17:25 CEST
Investigating
We are currently investigating the issue.
October 9, 2025 · 17:10 CEST
← Back